Increased declines by Issuer (Piraeus Bank)
Incident Report for Viva Wallet
Resolved
Transactions declines/approvals are back to normal.
Posted Sep 13, 2021 - 03:03 EEST
Investigating
We have identified increased declines from issuer: Piraeus Bank, issuercountry: GR, affecting all our acquiring transactions that require their approval.
Posted Sep 13, 2021 - 02:43 EEST
This incident affected: Third Parties.