Increased Rejections on Outgoing Instant SEPA Bank Transfers.
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 14:53 EET
Monitoring
National Bank of Greece is experiencing technical issues, Instant Outgoing Bank transfers are being rejected and credited back to our Customer's Accounts.
Posted Jan 21, 2023 - 14:29 EET
This incident affected: Money Transfers and Bill Payments.