Increased declines by Issuer Revolut
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 13:09 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2023 - 13:00 EEST
Identified
Card issuer Revolut is experiencing technical issues. An increased number of Card not Present and Card Present transactions are not processed
Posted Sep 05, 2023 - 12:58 EEST
This incident affected: Payment Acceptance.