Degraded performance on our 3DS flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted May 10, 2022 - 00:16 EEST
Investigating
Card issuer: Eurobank EFG (GR) is experiencing technical issues. A number of e-Commerce transactions are not being processed.
Posted May 10, 2022 - 00:01 EEST
This incident affected: Payment Acceptance and Third Parties.