Increased declines by Issuer (National bank of Greece)
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 03:57 EEST
Investigating
We have identified increased transaction declines by card issuer: National bank of Greece
Posted Oct 15, 2021 - 01:55 EEST
This incident affected: Payment Acceptance and Third Parties.