Vivawallet.com - scheduled maintenance
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted May 13, 2022 - 19:44 EEST
Investigating
Our website is currently unavailable due to scheduled maintenance. The expected downtime is up to 30 mins
Posted May 13, 2022 - 19:17 EEST
This incident affected: Self Care.