Increased declines by Issuer (Eurobank)
Incident Report for Viva Wallet
Resolved
Transactions serviced by card issuer: Eurobank are operating normally.
Posted Oct 02, 2021 - 13:00 EEST
Investigating
We have identified increased transaction declines by card issuer: Eurobank
Posted Oct 02, 2021 - 12:00 EEST
This incident affected: Payment Acceptance and Third Parties.