3DS service issue
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted May 18, 2021 - 17:34 EEST
Investigating
3DS service is facing performance issues. We are investigating the issue
Posted May 18, 2021 - 17:22 EEST
This incident affected: Payment Acceptance and Third Parties.