Degraded performance on our 3DS transaction flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 23:06 EET
Investigating
Card payment scheme: Visa is experiencing technical issues. An increased number of e-Commerce transactions are not processed
Posted Jan 05, 2022 - 22:44 EET
This incident affected: Payment Acceptance and Third Parties.