Degraded performance on our 3DS transaction flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 17:05 EEST
Investigating
Card Payment Scheme: Mastercard is experiencing technical issues, causing a number of e-Commerce transactions not to be processed
Posted Sep 20, 2022 - 16:30 EEST
This incident affected: Payment Acceptance.