Degraded performance on our 3DS transaction flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 12:45 EET
Investigating
Card payment scheme: Mastercard is experiencing technical issues. An increased number of e-Commerce transactions are not processed
Posted Nov 18, 2021 - 12:15 EET
This incident affected: Payment Acceptance and Third Parties.