3DS service issue
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 19:59 EEST
Investigating
Visa is experiencing network connectivity issues affecting Card no present transactions
Posted Jun 16, 2021 - 19:39 EEST
This incident affected: Payment Acceptance and Third Parties.