Vivawallet.com - Maintenance
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 00:48 EEST
Investigating
Our website is currently unavailable due to maintenance. The expected downtime is up to 30 minutes.
Posted Sep 13, 2022 - 00:10 EEST
This incident affected: Self Care.