Bancontact outage
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 11:05 EEST
Investigating
Bancontact services are not responding
Posted Jul 21, 2021 - 10:50 EEST
This incident affected: Third Parties.