Alpha Bank Greece is down.
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Apr 25, 2021 - 04:58 EEST
Identified
It seems that Alpha Bank is having some issues providing declines in their responses affecting our transactions
Posted Apr 25, 2021 - 04:00 EEST
This incident affected: Third Parties.