x
Follow @VivaWalletStat
or
view our profile
.
Visit our
support site
.
Increased declines by Issuer (Eurobank)
Incident Report for
Viva Wallet
Resolved
This incident has been resolved.
Posted
Oct
04
,
2021
-
20:34
EEST
Investigating
We have identified increased transaction declines by card issuer: Eurobank
Posted
Oct
04
,
2021
-
19:55
EEST
This incident affected: Payment Acceptance and Third Parties.
×
Subscribe to Incident
Subscribe to updates for
Increased declines by Issuer (Eurobank)
via . You'll receive .