Network connectivity issues with card payments scheme: Visa
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 14:38 EET
Investigating
Network connectivity with Visa is seriously degraded. Most transactions serviced by Visa experience delays or failures
Posted Jan 17, 2023 - 14:08 EET
This incident affected: Payment Acceptance and Third Parties.