Degraded performance on our 3DS transaction flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Nov 28, 2021 - 04:14 EET
Investigating
Card issuer: National Bank of Greece is experiencing technical issues. An increased number of e-Commerce transactions are not processed
Posted Nov 28, 2021 - 03:00 EET
This incident affected: Payment Acceptance and Third Parties.