Performance degradation due to Microsoft Azure connectivity issues
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted May 20, 2021 - 22:35 EEST
Investigating
Performance degradation due to Microsoft Azure connectivity issues
Posted May 20, 2021 - 19:00 EEST
This incident affected: Payment Acceptance and Third Parties.