Alpha bank is down
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 21:59 EEST
Investigating
Alpha Bank is having some issues providing declines in their responses affecting our transactions
Posted Jul 23, 2021 - 21:40 EEST
This incident affected: Third Parties.