Increased declines by Issuer (Piraeus Bank)
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 03:56 EEST
Investigating
We have identified increased transaction declines by card issuer: Piraeus Bank
Posted Oct 15, 2021 - 03:17 EEST
This incident affected: Payment Acceptance and Third Parties.