Degraded performance on our 3DS transaction flow
Incident Report for Viva Wallet
Resolved
This incident has been resolved.
Posted Jan 16, 2022 - 03:59 EET
Investigating
Card issuer: National Bank of Greece is experiencing technical issues. An increased number of e-Commerce transactions are not processed
Posted Jan 16, 2022 - 02:05 EET
This incident affected: Third Parties.