Alpha Bank Greece is down.
Incident Report for Viva Wallet
Resolved
Incident has been resolved
Posted Feb 28, 2021 - 00:50 EET
Identified
It seems that Alpha Bank is having some issues providing declines in their responses affecting our transactions
Posted Feb 28, 2021 - 00:41 EET
This incident affected: Third Parties.